Yamaha YZF R125 Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi. I have had this yzf 2011 for some time now without any bigger issues. But in the past month it started destroying spark plugs. They come out white and ashy and it won’t start unless I change it. But yesterday it didn’t start even tho I gave it the new spark plug but then I noticed fuel pump was completely silent so I checked the fuses (they were all fine). I tried turning the key some hours later and suddenly the pump turned on and the bike started. I really don’t want to be stuck somewhere. Can it be that the fuel pump is not working properly and the motor is not getting enough fuel and the pump doesn’t always want to even start?
 

·
Super Moderator
2008 YZF-R125 (180cc)
Joined
·
658 Posts
This does indeed sound like maybe a fuel pump issue. In my (limited) experience they don't usually just fail outright, they get weaker and then start being intermittent.

> I really don’t want to be stuck somewhere.
and that's exactly what would happen.

White/ashy spark plug deposits suggests running lean (lack of fuel) which is another thing pointing at fuel supply as a problem.

Changing the fuel pump on a gen1 is relatively easy. The main head-scratcher is how to remove the big plastic lock-ring whcih holds the pump assembly in, but it 'just' unscrews. First time I did mine it was stuck pretty tight, I think a bit of wd40 in the threads and probably twisting some fabric around the lid (like using a wet tea towel to open a jar) did the trick. . (sorry, was a while ago).

It's possible it's somethgin else but certainly there's a pretty strong case for it being the pump.

Good diagnosis, info and conclusions on your part, spot on :)
 
1 - 3 of 3 Posts
Top