R125Forum.com banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4,450 Posts
Discussion Starter #1
Someone has stolen the little rubber strip that runs along top of my screen.

Sent from my iPhone using Forum Runner
 

·
Administrator
Joined
·
10,701 Posts
Scott Murphy said:
Someone has stolen the little rubber strip that runs along top of my screen.

Sent from my iPhone using Forum Runner
Serious
 

·
Premium Member
Joined
·
6,114 Posts
The one I gave you with the screen!?

LOL PMSL - Sorry I am not laughing at you, but the fact that people go out and do this stupid shiz!!!!
I might have some more bro, I'll need to look around my room
 

·
Administrator
Joined
·
10,701 Posts
Lol yeah I put it back on last night and just went to shop and it not on my screen now.

Sent from my iPhone using Forum Runner[/quote
because sometimes they blow off when wind hits it at high speed my one was blowing off when i was on the A40 but people do nick them
 

·
Registered
Joined
·
4,450 Posts
Discussion Starter #7
d-r125 said:
The one I gave you with the screen!?

LOL PMSL - Sorry I am not laughing at you, but the fact that people go out and do this stupid shiz!!!!
I might have some more bro, I'll need to look around my room
Cheers Dervis but I like how it looks without rubber strip. My stock screen never had rubber edge.

Sent from my iPhone using Forum Runner
 

·
Administrator
Joined
·
10,701 Posts
Cheers Dervis but I like how it looks without rubber strip. My stock screen never had rubber edge.

Sent from my iPhone using Forum Runner
stock screen had a lip on it
halfords sells the rubber bit
 
1 - 11 of 11 Posts
Top