Yamaha YZF R125 Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
hi all my son has bought a 2009 yzf r125 at first he could not change the gears correctly and the speedo wasnt working so i checked it out found out its a newer engine (e3j4e) fixed speedo and newer gear change mech so gears corrected as 14/18 has a reverse gear fitted on them he wants to fit a power commander as he has a full race pipe and he wantsa performance air filter and a 189 kit but we have a problem the bike still has a 2009 wiring and ecu also it has a o2 sensor fitted but the wiring is missing in loom so we able to fit 2009 commander as its a 2014/2018 engine and i fit a newer commance etc the the wiring loom and ecu has any one had a same problem cheers karl
 

·
Registered
2008 YZF-R125 (180cc)
Joined
·
503 Posts
as far as I'm aware if you're anting to do power commanders and big bore kits you need to be on gen1 ecu + wiring. The narrowband o2 sensor in the mix on gen2 wiring will just mess you up if you try to fit a power commander (power commander adjusts fuelling, o2 sensor compensates.. repeat ad infinitum).

The rapidbikes evo kit does apparently work on 2014-2016 (gen2) bikes and supposedly works wiht the narrowband o2 sensor, but the only person to have done that build hasn't had much luck with it, so seems like gen1 is possibly still the way to go if you want to tune, go big-bore etc.

If you have gen1 wiring then you should be able to ignore the o2 sensor. There is no o2 sensor on the gen1, it's not been removed from the loom. Though if you fit a PCV + autotune (or similar setup) you may need to add a bung for a wideband o2 sensor, but that's a different sized sensor too.

hope that helps :)
 
1 - 2 of 2 Posts
Top