Yamaha YZF R125 Forum and Owners Club: Friendly bike community for all. Bike Will Not Start | R125 Forum
Change
  1. BOTM Winner
    Congratulations grayej! You are the winner of November's BOTM competition!

    Please visit the BOTM section to see more entries, or to enter this month.

    Click here to enter!

Bike Will Not Start

Discussion in 'General Chat' started by CARMEL PEREGIN, Feb 19, 2020.

  1. CARMEL PEREGIN

    CARMEL PEREGIN

    Current Bike (Optional):
    YZF-R125
    License Currently Held:
    UK Full Bike
    Hi all.I've got a 2014 YZF-r125 and since changing the ignition switch there is no power at all,no dash lights,no fuel pump priming and no blown fuses. Can any one help please
  2. R125Forum.com Advertisement

  3. Captain Slow

    Captain Slow Super Member

    Location:
    Fleetwood, Lancashire
    Current Bike (Optional):
    R125, R3, CBR929RR, R1
    License Currently Held:
    UK Full Bike
    It sounds like you have a bad electrical connection into the bikes wiring loom from the new ignition switch. Check the main red wire and also the grey/blue.
  4. CARMEL PEREGIN

    CARMEL PEREGIN

    Current Bike (Optional):
    YZF-R125
    License Currently Held:
    UK Full Bike
    Checked sad wires and there is power coming to them yet still no life in dash lights/headlights or indicators. Battery fully charged and fuses all ok.
    Where can I find the starter solenoid ?
  5. CARMEL PEREGIN

    CARMEL PEREGIN

    Current Bike (Optional):
    YZF-R125
    License Currently Held:
    UK Full Bike
    Thanks for all your help. Problem solved,....Broken wire on ignition switch,now good as new
    NorthCust likes this.

Share This Page