Yamaha YZF R125 Forum and Owners Club: Friendly bike community for all. Bike Start Button Doesnt Work | R125 Forum
Change
  1. BOTM Winner
    Congratulations grayej! You are the winner of November's BOTM competition!

    Please visit the BOTM section to see more entries, or to enter this month.

    Click here to enter!

Bike Start Button Doesnt Work

Discussion in 'Technical / Mechanical Discussion' started by Sushan, Aug 18, 2019.

  1. Sushan

    Sushan New Member

    Current Bike (Optional):
    YZF R125
    License Currently Held:
    UK Provisional (CBT)
    My bike doesnt start at all. Bike start button doesnt work and I cant hear any clicks .. I tried to bump start and it didnt work either .. I checked the fuses and fuel is new as well as I recently topped it up . What can my problem be . I tried eveything.. I tried checking the starter and it does make the engine turn over.
    NorthCust likes this.
  2. R125Forum.com Advertisement

  3. NorthCust

    NorthCust Active Member

    Home Page:
    Current Bike (Optional):
    2008 Yamaha R125
    License Currently Held:
    UK Full Bike
    ok dunno if i can help but here goes:

    - when you turn the key does your speedo/display light up?

    - if your speedo/display lights up is it giving any error codes (flashing ecu light)?

    - what is the battery voltage? (use multimeter)

    - when you turn the key do you get the fuel pump whirring noise momentarily?
    [sounds like a no from what you've said?]

    - when you push the start button does the bike turn over?
    [sounds like no but perhaps you tested the starter motor itself on a battery?]
  4. Captain Slow

    Captain Slow Super Member

    Location:
    Fleetwood, Lancashire
    Current Bike (Optional):
    R125, R3, CBR929RR, R1
    License Currently Held:
    UK Full Bike
    If all above isn't working then take the kill switch apart and clean the contacts. Don't loose the ball bearing when you strip it down!
    NorthCust likes this.
  5. Sushan

    Sushan New Member

    Current Bike (Optional):
    YZF R125
    License Currently Held:
    UK Provisional (CBT)
    im also wondering if it is this ...i like checked everything apart from kill switch
  6. NorthCust

    NorthCust Active Member

    Home Page:
    Current Bike (Optional):
    2008 Yamaha R125
    License Currently Held:
    UK Full Bike
    well there's not much to the switch..I guess it might be worth checking there's voltage going to the wires while you're in there?
  7. Captain Slow

    Captain Slow Super Member

    Location:
    Fleetwood, Lancashire
    Current Bike (Optional):
    R125, R3, CBR929RR, R1
    License Currently Held:
    UK Full Bike
    In
    My experience its crap from riding in all weathers that mess up the brass contacts.
    NorthCust likes this.
  8. DAMIAN

    DAMIAN

    Current Bike (Optional):
    My R125
    Have you checked the relays under passenger seat? If not second in on left if sitting on bike is starter one

Share This Page